Symptom
WATS Client has increasing pending reports. WATS.log contains messages resembling this:
Exception {
Type="System.ServiceModel.Security.MessageSecurityException";
Message="An unsecured or incorrectly secured fault was received from the other party. See the inner FaultException for the fault code and detail.";
Source="mscorlib";
TargetSite="Void HandleReturnMessage(System.Runtime.Remoting.Messaging.IMessage, System.Runtime.Remoting.Messaging.IMessage)";
HelpLink="";
StackTrace="
Server stack trace:
at System.ServiceModel.Channels.SecurityChannelFactory`1.SecurityRequestChannel.ProcessReply(Message reply, SecurityProtocolCorrelationState correlationState, TimeSpan timeout)
at System.ServiceModel.Channels.SecurityChannelFactory`1.SecurityRequestChannel.Request(Message message, TimeSpan timeout)
at System.ServiceModel.Dispatcher.RequestChannelBinder.Request(Message message, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)
Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at Virinco.WATS.Interface.ReportCenter.IReportCenter.GetVersion()
at Virinco.WATS.Interface.TDM.IsConnectedToServer(Boolean PingServer)";Exception {
Type="System.ServiceModel.FaultException";
Message="An error occurred when verifying security for the message.";
Source="";
TargetSite="";
HelpLink="";
StackTrace="";
}
}
To verify the local time on the client, you can run the following command in a command prompt:
w32tm /stripchart /computer:pool.ntp.org /samples:5
This will check the local time against a public time server in the global ntp.org pool.
Cause
The most common cause for increasing pending report is time skew. WATS Report delivery is based on Microsoft WCF Technology which has a built-in security feature that disallows communication if time-skew is off by more than 5 minutes between the client and the server.
Possible solutions
Correct the clock.
See the following article for recommendations on time syncronization: https://virinco.zendesk.com/entries/22933457-Time-Synchronization
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